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Copyright Baldor   2002. All rights reserved.
Baldor makes no representations or warranties with respect to the
contents hereof and specifically disclaims any implied warranties of
fitness for any particular purpose. The information in this document is
subject to change without notice. Baldor assumes no responsibility for any
errors that may appear in this document.
Microsoft and MS–DOS are registered trademarks, and Windows is a
trademark of Microsoft Corporation.
UL and cUL are registered trademarks of Underwriters Laboratories.

What is WorkbenchD  SW794
WorkbenchD is a software tool used to configure Series 29, 30 and 38
controls. WorkbenchD runs on a PC compatible and has a graphical user
interface that uses drawing tools that allow you to program the control
quickly and easily.  Use the mouse  to create and diagram your
configuration in an easy–to–understand visual format that represents your
configuration.  WorkbenchD is used to program the control rather than
using the keypad.  Source / Destination tags are connected using the
cursor to “drag” connections together.  Double clicking on a block allows
each parameter value to be set.
Using WorkbenchD you can create an application, install the application in
the controls memory, upload an application from control memory and save
the application to disk.
� Create configurations for controls
� Install configurations into controls
� Modify configurations for controls
� Retrieve configurations from controls
You do not have to be connected to a control to create your system
configurations.  You may create the entire system off–line and then
connect the PC to the control to install to program to your drive.
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Installing Software on your PC
The setup software is Windows–based.  The servo control connects to a
serial port on your PC.  The setup wizard will guide you through the
necessary steps to set–up your servo control.  Online–help to each topic
is available.

Hardware requirements (minimum):
Processor: Intel 80486 / 33 MHz
RAM: 8 MB
Hard Disk Space: 5 MB
Screen: 600 x 480 (minimum)
Recommended: Intel Pentium, 64 MB RAM, 133 MHz, 100 MB Free Space
COM Port: DB9 connector (not USB) to interconnect to control.
Cable: CBLD030P3 – for P3 to COM port connection (3 meters)

Software requirements:
Operating system: Windows 95  (minimum)
Recommended: Win98 or Windows 2000

Installation  The following procedure will install the setup software on
your computer’s hard disk:
1. Start Windows.  Make sure that no other programs are running during

this installation.
2. Place installation Disk #1 in your computer’s floppy drive.
3. Run A:\Setup.exe (if A:\ is your floppy drive) or double click the file

Setup.exe from My computer, 3.5 inch Floppy (A:).
4. Follow the instructions and insert the other installation disk(s) as

required.
Host Communications Setup
Be sure the communications port of the PC is correctly set for
communications with the Drive software.  The following examples assume
COM1 of the PC is used.  If you are using COM2 – 4, substitute the
correct COM port number in the example.
Windows 3.1 Terminal Emulation
1. Power up the Host and start Windows software.
2. In the “Windows Accessories Group” select “Terminal” ICON.
3. Select “Communications” from the Settings pull down menu within

Terminal program.
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4. Set the communications settings for:
19200 Baud rate
8 Data Bits
1 Stop Bit
No Parity
Xon/Xoff Flow Control
COM1

5. Select “Binary Transfers” from the Settings pull down menu within
Terminal program.

6. Set the Binary Transfer protocol to XModem/CRC.
7. Close menu and save the settings.
8. Terminal Communications settings are now complete.

Windows 95
1. Power up the Host and start Windows software.
2. In “Control Panel” select and open “System”.
3. Open “Ports”, select the COM port you are using then click

“properties”.
 

4. Be sure the port settings are as: Bits per second=19200, Data bits=8,
Parity=none, Stop bits=1 and Flow control=Xon/Xoff.
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Windows NT
1. Power up the Host and start Windows software.
2. In “Control Panel”, select and open  “Ports” then click “Settings”.

 

3. Be sure the port settings are as: Bits per second=19200, Data bits=8,
Parity=none, Stop bits=1 and Flow control=Xon/Xoff.

Using The Setup Wizard
The setup software wizard guides you through each step to set the basic
parameters. There are two diskettes (SW794) in your WorkbenchD
package for Windows 95 or NT installation.  With Windows launched,
insert disk 1 and type a:setup under Start|Run for Windows 95 and NT.
Then follow the prompts while setup guides you through the install
process. 
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From the COMMS drop down menu, set the communications settings.

Select a serial port (COM1, COM2, COM3, or COM4) and then select one
baud rate (2400, 9600, 19200, 38400, or 57600). Make sure the serial
port you select is not the same one being used by the mouse. If the
mouse is connected to COM1, you would normally use COM2 for your
drive connection.  19,200 baud is recommended.
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Select “File→Page Setup” to configure the printer you are going to use.
Since WorkbenchD creates drawings in a horizontal format, make sure
your page is set for Landscape mode.

Installation is now complete.

Communicating with the Control
A communications cable must be connected between the COM port of the
PC and the P3  port of the control.  Refer to the control manual to locate
this P3 connector and connect the cable CBLD030P3.  At the control,
several parameter values must be set using the keypad.

1.  SERIAL LINKS::SYSTEM PORT::P3 SETUP::MODE to EIASCII.
2.  SERIAL LINKS::SYSTEM PORT::P3 SETUP::P3 BAUD RATE to 19200.
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Create/Save a Configuration
From the File menu, select New then choose from a list of all available
template configurations. Selecting New again brings up a directory listing
all default or template configurations available to you. Select a file name
from the directory list and click on OK. 
 

When the file opens, the page may be off center and the wrong
magnification factor.  Press “7” (for normal full page viewing) to change
zoom factor and use the page scroll bars to center the image.  Notice the
gray outline frame surrounding the window. If the gray outline is not
visible, try scrolling down or to the right until it appears. This frame marks
the limits of the “page” (see “File→Page Setup”). You must allow an extra
margin inside the gray outline for the edges of the paper where the printer
cannot print. Items extending beyond the gray outline will not print.
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Key Description
0 Scales to 10pt. font (1.67x drawing)
1 Scales to 11pt. font (1.83x drawing)
2 Scales to 12pt. font (2.00x drawing)
3 Scales to 3pt. font (0.50x drawing); homes to upper left
4 Scales to 4pt. font (0.67x drawing); homes to upper left
5 Scales to 5pt. font (0.83x drawing)
6 Scales to 6pt. font (1.00x drawing)
7 Scales to 7pt. font (1.17x drawing)
8 Scales to 8pt. font (1.33x drawing)
9 Scales to 9pt. font (1.50x drawing)
+ Increases scaling by factor of 1.33
– Decreases scaling by factor of 1.33
Home Sets origin of view to upper left corner
Page Up Moves view of drawing up by 7/8 of current size
Page Down Moves view of drawing down by 7/8 of current size
Up arrow Nudges view of drawing up
Down arrow Nudges view of drawing down
Left arrow Nudges view of drawing to the left
Right arrow Nudges view of drawing to the right
Shift Page Up Moves view of drawing to previous sheet
Shift Page Down Moves view of drawing to next sheet
Backspace Deletes currently–selected item
Save the configuration by selecting “File→Save As” and then name the file.
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Display/Change Parameter Values
To display the parameters of a particular function block, double–click the
block with your mouse. This opens a window listing all the parameters for
that function block. Connections are also shown.  Parameter values may
be changed but connections cannot be changed in this menu (see
Changing Connections Between Blocks). 
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Changing Connections Between Blocks
Connections between outputs and inputs are made using the mouse to
drag the connection from an output to an input. Use the mouse to select
the Analog Input 2 output. Click and hold the mouse button and drag the
dotted connection line to the Sign0 input of Setpoint Sum 1 block. The
new connection is made.  To delete a connection, click on the connection
and press the keyboards “Delete” key.  Save the configuration when done.

Align Function Blocks
If you have moved some of the blocks or added a new block, you may
want to align several blocks so they are aligned either vertically or
horizontally.  Click on the box that is in the correct position.  Next, select
“Draw→Align” (a check mark will appear next to align).  Select each
element you want to align with the first, drag it to the general location you
want, and release the mouse key. It will automatically snap into alignment
with the original block. You can turn the alignment feature off by clicking
on an empty section of the drawing (so no function block is selected) and
selecting “Draw→Align”. The check mark will now be gone.  Save when
done.
Install a Configuration
When your configuration is completed, it must be installed into the drive.
To install a configuration, the computer must be connected to the drive’s
P3 port. The P3 port mode must be set to ASCII and the baud rate must
be set to match the PC’s baud rate (19200).  The new configuration
should be installed only when it is safe so that if the program has an error,
it will not cause harm or damage to persons or equipment.
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To install a configuration into a drive, first open the configuration to be
installed “File→Open” and make sure it is the selected configuration if
more than one is open. Select “Command→Typical Install”  to begin the
download process.  (“Full Install” also overwrites motor data and is not
normally used).

The configuration is downloaded to the control and the parameters set in
the configuration replace the existing values stored in the drive. A status
box displays the progress of the Install procedure.

Update a Configuration
When a configuration is installed in the control memory, it can be retrieved
to WorkbenchD, changed and downloaded to the controls memory.
To retrieve a configuration, the PC must be connected to the control’s P3
port. The P3 port mode must be set to  EIASCII and the baud rate must
be set to match the PC’s baud rate (19200).  The configuration should be
retrieved or installed only when it is safe so that if the program has an
error, it will not cause harm or damage to persons or equipment.
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Select “Command→Get Info” to make sure the connection to the drive is
good and the drive is not running. The results of your Get Info query will
appear in the scratch pad area.
Select “Command→Update” to retrieve the configuration from the control
memory.  A status box displays the progress. When complete, the
configuration on the display will be the one that was stored in control
memory.  Save the configuration to a new file name. 

Create a Configuration Template
Template files are useful for reusing configurations and creating standard
graphical presentations. They are not overwritten when saving a
configuration.  To create a template, open a configuration and modify it as
needed. Select “File→Save As”.  Change the file name (or destination
directory if desired) and choose OK to close the configuration file. If this
file is stored in the New directory, it will appear in the pop down menu
when selecting New in the File menu.
Print a Configuration File
Be sure the page and printer setup are completed correctly, then print a
copy of your configuration by selecting “File→Print”.
Document a Configuration File
It is very helpful to have a printed reference listing of configuration
connections and parameter values. This is similar to a source code listing
for other programs.  First, make sure the desired configuration is opened
and selected. Then select “File→Document”.  A dialog box  is displayed
so you can name the documentation file and assign it to a directory of
your choice.  This file can be opened and printed using a text editor or
word processor.
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Sample:
Parameters by Function Block:
Diagnostics
..(207) Speed Feedback (%) ......... 0.05 %      <READ–ONLY>
..(297) Speed Error (%) ............ –0.05 %     <READ–ONLY>
..(299) Current Demand (%) ......... 0.00 %      <READ–ONLY>
..(298) Current Feedback (%) ....... 0.00 %      <READ–ONLY>
..( 87) Pos. I Clamp (%) ........... 200.0 %     <READ–ONLY>
..( 88) Neg. I Clamp (%) ........... –200.0 %    <READ–ONLY>
..( 67) Actual Pos I Lim (%) ....... 200.0 %     <READ–ONLY>
..( 61) Actual Neg I Lim (%) ....... –200.0 %    <READ–ONLY>
..( 84) Drive Enable ............... Disabled    <READ–ONLY>

Create/Edit a Form
An outline or border inserted around your configuration diagram provides
a uniform appearance when printed. Adding important text material can
help make your diagrams more clear and easier to understood.
Workbench D contains special drawing tools that let you design and
produce your own forms and insert descriptive text. These forms
(containing both graphical and text material) are stored as .frm files in
WorkbenchD’s working directory. By now, you have learned that your
configuration diagram must reside within the gray border that appears on
your computer screen in order to be printed. When you add a custom form
to your diagram, that form must also reside within the gray border. The
form will appear on your screen and your diagram must then be placed
within its borders to be printed.
Note: The gray border represents the page size, not the printable area.

Make sure to leave a margin inside the border to suit your printer.
To create a custom form, you must be in a configuration window. You can
either open an existing configuration or create a new one from the File
menu.
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A new configuration will appear on screen. You may now use the tools in
the Draw menu to create your form.
Note: Sheet 0 is designed only for creating forms or adding information

that will print on every page of the current configuration. Do not
place items on sheet 0 that you do not want reproduced on every
page in that configuration.

Go to the Draw menu and confirm you are on sheet 1. Forms are created
on sheet 0, so select “Draw→Prev Sheet” to move to that sheet. You will
be prompted with a dialog box asking if you want to edit the form. Click
Edit.  The sheet 0 will appear for editing.   

Be sure the view scale allows you to see the gray borders at the bottom
and right side of your window. If the gray border is not visible, select a
different magnification “Draw→Scale→0.67x”.
The drawing tools are used to add shapes, graphics and text that will
appear on each page.  Select a line and press the delete key to remove
that line (or select Edit→Clear).  To draw a line, select “Draw→Line”. The
cursor changes to a crosshair in the shape of an x. Click and hold the
mouse button as you move the mouse; notice that a line begins from the
center of the crosshair. Carefully draw a line inside the gray border at
either the bottom or right side of your configuration window. Make sure the
line is straight and where you want it. If not, click once on the line and hit
the Delete key to remove it.
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When you reach the end of the first line, press and hold the Ctrl key and
click and hold the mouse button until you reach the end of the next line
segment.

Note: Holding down the Ctrl key when you click the mouse button
repeats the previous operation allowing you to continue drawing or
adding text, whichever was last done. In this example, we can add
a second line starting at the end point of the first.

To add text, select “Draw→Text”.  Click where the text should begin and
start typing.  If the type is too small, or you want to change the typeface or
style, select the type with the mouse. You may have difficulty clicking on
the type inside the box because, as was mentioned earlier, boxes created
with the rectangle tool are filled. In that case, click once in the box and
then go to the Draw menu and select Move to Back.  This moves the box
to a layer behind the text block but still on the same sheet of the diagram.
Click the type block; a gray box will appear around the type. Once
selected, the type may be changed using the Font and Style menus. The
text box, like any object can be dragged to a new position.
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Automatic Data Entry
Text can be added that is coded to receive data automatically from your
configuration specifications. The Baldor configuration diagram shown here
and uses several codes for filename, date etc.

SIZE A DWG NO.

^I^C ISSUE 1

SCALE
^D

SHEET          ^S    OF  ^N

� ^C (the configuration name)
� ^D (the date of the last modification to the configuration)
� ^I (the directory in which the configuration resides)
� ^N (the number of sheets in the diagram)
� ^S (the current sheet number)
Note: Make sure you enter the codes exactly as they are given in the

Format Code table. Case is critical. The caret (“ ^ ” above the 6 on
the keyboard) indicates formatting information for forms and text
entered on sheet 0 only and should not be used on other sheets.

Save/Insert a Form
When the design of your form is completed save the form by selecting
“Draw→Save Form”. A dialog window will ask you to name the form.  In
the future, this form can be used by simply inserting it into the new
configuration file.  To do this, open a new configuration file, go to sheet
zero and select “Draw→Insert Form”.  Pick the form you want to insert
and it is placed on sheet 0.
You cannot have different forms for different sheets in the same
multiple–sheet configuration. Only one form may be selected for each
configuration. It is placed on sheet 0 and appears on every sheet of that
configuration. Forms may be removed from configuration diagrams by
selecting “Draw→Remove Form” and then choosing the form to be
removed. Selecting “Draw→Show Form” makes the form visible while
working on the configuration and for printing.  (It must be selected for the
form to appear in the printout).
Function Blocks
Parameters are arranged into groups called “Function Blocks”. Function
blocks are graphic programming tools. You can visually locate a group or
block, connect it’s inputs and outputs to other blocks and open it to set the
parameter values associated with that function block. When making
connections between blocks, the connection is made from the output side
of a function block.  For example,  to connect the Max Value input of the
Analog Input 2 block click and hold down on the line at the right of the
block that corresponds to the Max Value Input.
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Drag the mouse to make the connection.  Do not try to click on the lines
on the left of the block, only the lines on the right may be used for
connections.  

±10V w/o Ramp
Analog Input 2
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Connections between function blocks on different sheets are possible. To
make inter–sheet connections, do the following.
1. Begin a connection from an output terminal of a function block on

sheet1 (or sheet 2).
2. Hold the mouse button down and drag the connection to the Draw

menu and select Next Sheet. Notice that the connection line
becomes a dashed line.

3. Complete the connection to a  function block input terminal on the
other sheet. The dashed line will change to a solid line. It will be
labeled with generic text identifying the connection and the source
sheets (for example, ITEM 1 SHT 1).

4. On the previous sheet, the text will show the destination sheet for the
connection (for example, ITEM 1 SHT 2).

5. Rename the connection by double–clicking on the arrow or the
descriptive text to bring up a dialog box.  Enter the label you prefer.
The new information will appear on both sheets.

Split Connections
Similar to inter–sheet connections, split connections can help keep
complex configurations from being cluttered with many lines that cross
over each other. Split connections resemble inter–sheet connections in
that they include labels identifying their source and destination. Split
connections may also be made in read–only configurations, since only the
on–screen appearance has been modified and the connection itself has
not been changed. To draw a split connection:
1. Choose a connection between two distant function blocks.
2. Double–click the connection with the mouse pointer or click once and

press the Enter key. A dialog box will ask for a name for the
connection.
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3. Enter the name and click the OK button. The connection will be split
and labels will be attached to each end identifying the source and
destination of the connection.

4. To change the connection name, double–click either the connection
or the label and enter the new information in the dialog box.

Drawing Tools
Creating configurations graphically is a main feature of Workbench D. The
Draw menu contains a variety of tools to assist you in your work. These
commands are used to modify objects drawn in or text added to the
configuration. The color, fill, or width of the lines of function blocks and
connecting lines cannot be modified. Only objects or lines you have drawn
in a configuration can be modified with these tools.
To apply color, fill, pattern, or width commands to an existing object, select
the object with the mouse pointer. Then select “Draw→Pattern” (for
example). A pop up list of pattern options will appear on screen; Hollow is
the normal pattern. Select a different pattern (for example, Solid) with the
mouse and release the mouse key. The box will automatically be filled on
screen. The normal fill setting is white.
Color The “Draw→Color” command is used to specify the outline
color for rectangles and ovals and the display color for lines, arrows, and
text you have added to your drawing. To apply color to an object or text,
either select a color and then a line or object to draw or text to place, or
select an already–placed object or block of text and then change the
color. The normal color setting is black.
Fill The “Draw→Fill” command is used to color the contents of an object
and highlight its appearance on a color display. To change the color for
new objects, select “Draw→Fill” and choose the new color. All new
objects will be drawn with that color. To change the fill color of an existing
object, select the object. Then select “Draw→Fill” and choose the new
color. The normal color setting is white.
Pattern  The Pattern command is used to set the fill pattern of an object.
To change the fill pattern for new objects, select “Draw→Pattern” and
choose the new style. All new objects will be drawn with that fill pattern.
To change the fill pattern of an existing object, select the object. Then
select “Draw→Pattern” and choose the new fill pattern. The normal
pattern setting is hollow.
Width The Width command is used to specify the thickness of lines
created with the Arrow, Line, Oval, and Rectangle commands. One point
is equal to 1/72 of an inch. Line width ranges from 0.5 points to 16.0
points; the normal line width setting is 0.5 points.
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Drawing Tools   Continued
Arrow The Arrow command is a variation of the Line command. It is
used to add lines with arrows to your drawings. Combined with text and
other tools, arrows can be an effective tool to bring attention to a particular
item.
Line The Line command allows you to draw straight lines anywhere in
your drawing. It can be used to create form outlines and text boxes, and
to add highlighting to drawings. When you select “Draw→Line”, your
cursor turns into an X, showing it is now a drawing tool. Place the X where
you want to begin your line.  Press and hold the mouse key, and drag a
line to the desired end point. Release the mouse key when your line is
finished. To draw a series of connected lines, hold the Ctrl key down when
you click the mouse the second time. A new line, starting where the first
one finished, can then be dragged with the mouse.
Oval The Oval command allows you to add an oval or circle to your
drawing. When you create an oval on screen, the borders formed during
the drawing process are rectangular. Only after you release the mouse
key does the oval appear. When you select the oval to move it or modify
its shape, it is highlighted by a rectangular gray box outlining its perimeter.
Rectangle The Rectangle command allows you to add a rectangle to your
drawing.
Text The Text command allows you to add text to your drawing.
Display Options
The zoom factor (Scale) and black & white background display options
are used to change the view of a configuration on your computer screen.
Scale
The Scale command selects the magnification ratio of your configuration
display. The “Draw→Scale” menu presents a list of preset ratios as well
as a variable dialog function. The variable dialog asks for a magnification
setting within the range of .34x to 10x. Keyboard commands may also be
used to change the scale.
Key Description
0 Scales to 10pt. font (1.67x drawing)
1 Scales to 11pt. font (1.83x drawing)
2 Scales to 12pt. font (2.00x drawing)
3 Scales to 3pt. font (0.50x drawing); homes to upper left
4 Scales to 4pt. font (0.67x drawing); homes to upper left
5 Scales to 5pt. font (0.83x drawing)
6 Scales to 6pt. font (1.00x drawing)
7 Scales to 7pt. font (1.17x drawing)
8 Scales to 8pt. font (1.33x drawing)
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Display Options   Continued
9 Scales to 9pt. font (1.50x drawing)
+ Increases scaling by factor of 1.33
– Decreases scaling by factor of 1.33
Home Sets origin of view to upper left corner
Page Up Moves view of drawing up by 7/8 of current size
Page Down Moves view of drawing down by 7/8 of current size
Up arrow Nudges view of drawing up
Down arrow Nudges view of drawing down
Left arrow Nudges view of drawing to the left
Right arrow Nudges view of drawing to the right
Shift Page Up Moves view of drawing to previous sheet
Shift Page Down Moves view of drawing to next sheet
Backspace Deletes currently–selected item
Ctrl + Mouse See object move
Object Move
Move blocks to arrange drawing sheets as follows:
1. Press the CONTROL (Ctrl) key.
2. Use the mouse to select (highlight) the block(s) to be moved.
3. Release the Ctrl and mouse button
4. Move the function block(s) to the new location.
5. After positioning the blocks, press the Ctrl key.
6. Click the mouse button.
7. Release the Ctrl key.
Black & White
The Black & White command is used to switch the display of your
configuration to/from color and monochrome (black and white) modes.
This is useful when taking a drawing created on a color monitor and
viewing it on a black and white monitor. It is also used when sending a
color configuration to a black and white printer. With this command set to
on, it prevents printing the drawing in gray scale, which may result in poor
printout quality.
Annotating Drawings
Objects and/or text may be added to your drawings in the same manner
as is used for creating forms.   Annotations made on individual
configuration sheets do not show on all sheets (as on sheet 0).
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Scratch Pad The scratch pad provides a written record of your actions
regarding the configurations, including loading, saving, and deleting
drawings. That record is kept in the WBenchD.tex file, which is created
automatically when you first launch Workbench D. Every time the program
is run, the information written to the scratch pad is added to the end of the
WBenchD.tex file. It is located in the working directory for Workbench D
(C:\Program Files\Baldor\ WBenchD\WBenchD.tex). The WBenchD.tex
file may be edited using any text or word processing program that reads
text files. The scratch pad window appears on screen whenever
Workbench D is launched. It responds to the same sizing commands and
actions as any other Windows’ element. The launch time for Workbench D
is recorded automatically in the scratch pad when the program opens. You
can manually insert the current time at any point by selecting Edit→Paste
Time menu.
It is a good idea to edit your WBenchD.tex file periodically, as it can grow
quite large. Before deleting portions of the file or the entire file, make a
copy (either printed or saved to a floppy disk) to retain for your records.
Scratch pad is opened each time you start WorkbenchD.  Entries are
automatically logged to create a historical record of each session.  When
WokbenchD is started, the entire log is not shown, only the logged entry
for the present session as shown here.  
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You can type comments into this file as part of the history record.  Simply
click into the are you want to edit and begin typing (or delete something).
This is an example of a comment entry.  
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Troubleshooting
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Communication Problems
Missing Communications Cable
A communications cable must be connected between the COM port of the
PC and the P3  port of the control.  Refer to the control manual to locate
this P3 connector and connect the cable CBLD030P3.
Mismatched Baud Rates
The baud rates in the drive must match those in Workbench D. Check the
BAUD RATE setting on the drive under SERIAL LINKS.
Baud Rate Set Too High
Some PC’s can experience difficulty with the 19200 baud rate. For those
computers, reduce the baud rate to 9600 on both the PC and in the
configuration file for the control.
Wrong Communications Port
Another common error is attempting to select a communications port
already in use, (typically by the mouse, COM1). Go to the
Command→Comms menu, select another communications port, and
ensure your control is connected to that port.
Drive P3 Mode Set Wrong
At the control, several parameter values must be set using the keypad.
SERIAL LINKS::SYSTEM PORT::P3 SETUP::MODE to EIASCII and 
SERIAL LINKS::SYSTEM PORT::P3 SETUP::P3 BAUD RATE to 19200
(to match the PC’s baud rate). 

Communication Quick Check (PC and Control)
Verify that these 5 items are correct.  Next, start WorkbenchD.  Select
“Command→Get Info” and verify the device ID appears in the scratch pad
area (“Device ID is 30D0, version 6.1” as shown here). This indicates
communication exists between the control and the PC.
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A sample error message (resulting from no cable installed at P3) is
shown.  See “Error Messages” for an explanation. 

Error Messages
Error detection is designed to help prevent the execution of an
inappropriate or dangerous command. Workbench D software displays an
error messages when it discovers a problem. The messages contain an
error number and a brief description. Some messages also have an error
code expressed as PNO plus a two–character code identifying the type of
error.
The most common error messages are as follows.
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Appendix A
Menus
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Menus When WorkbenchD is started, the main menu appears.  The
following pages describe the main menu selections.

File Menu

Start a new configuration.  (Only one configuration
can be open at one time).
Open an existing (previously saved) configuration.

Close the current configuration file.
Save the current configuration file to the current
filename.
Save the current configuration file to a different
filename.
Create a editable text file to document the parameter
values and connections.

Specify the scale factor of the printed configuration.

Specify printer and settings.

Send the configuration file to the printer.

Save the scratch pad, close the configuration file
and exit WorkbenchD.

Edit Menu   (Edits the Scratch Pad area of the WorkbenchD window)

Undo last change.

Save the active project page to a file.
Save the active project page to a different file than
the current filename.
Print your entire project, a summary, pages, alarms, or
variables.
Removes the selected text from the scratch pad entry.

Adds a date and time stamp at the
cursor position within the scratch pad.

Select all text within the displayed scratch pad entry
(not the entire file).

These commands only work with the displayed scratch
pad entry.  To make changes to the rest of the scratch
pad file, an editor must be used (notepad etc.).
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Command Menu     
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Draw Menu Drawing tools are used to change the appearance of a
selected item or to change the appearance of new items.  For example,
selecting a line and changing the width to1.5 will only change the width of
the selected line.  With no lines selected, changing the width to1.5 will
only change the line width for all new objects (not previously created
objects on the page). 
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Window Menu  

Identifies the parent file.

Identifies the Child file.

Identifies the sibling file.

 Displays names of presently opened files.

Allows a hierarchy of window organization.

Font & Style Menus  

Helvetica

Times

Defines the type style for text.

Courier

 3 to 72 point 
(1 inch) type size

Bolds text

italic

Underlined

Help Menu  

Displays the Help file.

Displays software revision information.
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